Introduction

STARR PC & Internet Monitor

STARR TM is the award-winning, highly flexible, all-round monitoring solution used by concerned parents, small businesses, and "Fortune 500" companies alike. STARR is also popular for many special tasks like usability testing or scientific studies of PC usage.

So how do you know what your staff (or family) are doing on your PCs? Are they working on your account - or playing solitaire? iOpus surveillance software can tell you exactly who is doing what on which PC at any time during the day or night.

Effective security on computers can save a computer user thousands of dollars every year - this stealth-monitoring utility provides the PCs equivalent of the security camera (and much more), increasing production dramatically, whilst causing no disruption to working practices or draining network resources and keeping those phone bills down.

STARR is available in a HOME Edition and in the full-featured PRO Edition. The HOME edition is designed for the use on a stand-alone PC, e. g. for parental control or for recording your own work for later reference. The PRO Edition contains all the features of the HOME Edition plus the network functions you need to send and receive reports via the Internet or the corporate LAN as well as advanced setup and reporting functions. A detailed feature comparison can be found here.

starr.gif (350 Byte) STARR Highlights:
 | Visual logging: See everything that happens on your PC with the built-in screenshot recorder. STARR creates an unique easy-to-read "all-in-one" interactive activity report.
 | Text Logging: Log keystrokes, user names, passwords, path names, access times, windows titles and send the log file by email, all invisible to the user. Fully searchable for keywords. This makes even the evaluation of large log files a snap !
 | "WEB Spy" : Record all URLs of visited websites. The report can made in plain text or HTML (just click & browse to the recorded sites). Works with all popular browsers !
 | "CHAT Spy": Record both sides of a chat conversation. This feature works with all leading chat software (AOL Instant Messenger, ICQ, Microsoft Messenger, Yahoo Chat). For all other chat software STARR does basic chat recording of all outgoing chats.
 | "AOL Spy": Record IM and chat conversations, emails and other content inside of AOL.
 | Receive the activity reports directly in your email. For maximum security and speed the report can be sent as password-protected, compressed ZIP file. [STARR PRO only]
 | Network functions: STARR can save the log files directly over a local area network (LAN) and has functions for Remote Deployment inside your LAN [STARR PRO only]
 | STARR is protected against manipulation: It runs invisibly, the log file is encrypted and setup und uninstall is password protected.
nn

Some Awards STARR won:
ZDNET 5 STAR AWARD | STARR was rated with 5 stars [image] at the famous ZDNET software library - the highest rating possible ! (
Tucows! | STARR received the highest possible [image] (5 cows) rating at the famous Tucows website, the leading website for internet related software!
 | STARR received the highest possible rating (5 stars) and the "Editor's Pick" at WebAttack, the world's largest collection of internet tools.
In addition to major web sites STARR is also featured in many printed magazines and radio shows. For example: |
xx

STARR wins awards because its design is based on real world experience: It creates *one* STARR Report File that contains everything that you choose to log (keystrokes, used applications, visited website links,....).The report files are fully searchable for specific keywords (e. g. "xxx") and thus makes the evaluation of the reports a snap ! This is especially important in a company settings where you need to keep an eye on many PCs. In contrast, surveillance software based only on "screenshots" might be nice to look at, but will cause you or your system administrators many hours of expensive, boring extra work sifting through all the screenshots. Also, the compact, single report files is ideally suited for archiving the results to satisfy legal requirements.


Invisible Installation

STARR Installation

The STARR installation wizard automatically creates a standard or an invisible installation for you.

In addition the professional version of STARR features support for a remote installation inside your local area network (LAN) of STARR. All STARR files are fully documented.

  1. Invisible Installation

  2. Remote Deployment [PRO Version]

  3. Installation Internals [PRO Version]


Invisible Installation

Invisible Installation of STARR

Basically there a two scenarios where an invisible deployment of STARR is used:

  1. Surveillance of a stand-alone PC, which means that one PC is both the Client and Administrator PC at the same time. This is the typical scenario when STARR is used on a family PC for parental control.

  2. Surveillance across a PC network (the "Client PCs") from an administrators PC. This is the typical scenario in a business, university or school environment [only PRO Version].

The STARR installation wizard automatically creates an invisible installation for you. Simply select the appropriate option during the installation. Remember, if you installed STARR invisible there is NO menu entry to start the STARR Commander. Instead, type "starrcmd" in the RUN menu. For added security you can also rename the starrcmd.exe file and/or password-protected the STARR Commander. For more information, go to the Settings section of this manual.

In addition to the automatic invisible installation, system administrators can further customize the installation of STARR PRO to suit their needs, for example files can be manually installed and renamed and/or the installation can by automated using the STARR Remote Deployment.

To start the STARR Commander type "starrcmd" in the windows RUN box (see screenshot). The RUN field is automatically cleared once you log off or the PC is shut down (It is not immediately cleared).


Network Settings

Local Area Network (LAN):

STARR Professional contains support for deployment and use on Local Area Networks (LAN).

A. Create individual log files (and reports)

You can create individual log files for each user and/or each PC by simply adding the <PC> and/or <USER> tags in the STARR log file name. Other available tags are <DATE>, <TIME>. STARR will automatically parse and replace the tags with the current PC name, user name, date or time.

Example:

You name the log file "log_<USER>.sys". Your users ( = user login name) are "PeterBrown", "AnnSmith" and "Administrator".

Starr creates the following log files:

  1. log_PeterBrown.sys

  2. log_AnnSmith.sys

  3. log_Administrator.sys

Note: On Win 9x/ME systems it is possible that a user does not log in. In this case, and for everything that happens before a login, the <USER> tag is replaced with "Nobody" so the recorded information can be examined separately.

B. Setup options for LAN networks

For log file storage and reporting there are two recommended options:

1. Store the STARR log file on a Administrator PC.

With this option no data is stored in the Client PCs. On the Administrator PC you can use the STARR Commander to create reports. For this option to work well the Client PC should have a permanent LAN connection. To rename the log file go to STARR Commander >> SETTINGS TAB >> Click ADVANCED SETTINGS. If it is not (e. g. laptops !) we recommend option 2:

2. Save the ready to use reports on the Administrator PC. With this option the STARR log itself is kept on the PC (unless you use option 1 as well). STARR sends the ready-to-use reports over the LAN to the Administrator PC. To rename the report file names go to STARR Commander >> EMAIL / LAN TAB >> Click LAN SETTINGS.

Note:
If you use option 2 you do not need to install the program on the Administrator PC (Server) but only on the workstations that you wish to monitor. If you have a peer-to-peer network without a server STARR will work equally well. The only requirement is a single shared folder that all machines have read/write access to. To create a shared folder that other workstations cannot see, append a "$" character to the folder's share name (i.e. "STARR$"). This folder should be on the server but it can be on any machine on the network. The network transport protocol is unimportant. STARR clears old records on the CLIENT PC automatically and needs no maintenance.

By using a shared folder the STARR reports (and the STARR log file) is always available to the Administrator - even if the source machine has been shut down.

C. STARR Deployment

Deploying STARR in a network is done by cloning the settings of a SOURCE machine. Since STARR is written as a very compact software only a few files are needed. The installation is transparent and can be easily automated. The source machine can be any PC on the networking running STARR, including this PC.

Remote Deployment for Networks is available to all users with a multi-user or site-license.

Typically there are 3 ways to deploy STARR:

Option 1: Network install

Copy all logging engine files to the appropriate folders on the CLIENT PC. To automate the first startup, copy "starr.lnk" to the start-up folder of the machine:

Windows Version | Typical locations of the start-up folder:
Win 95, 98, ME | C:\WINDOWS\Start Menu\Programs\StartUp
Win NT, 2000, XP | C:\Documents and Settings\XXX\Start Menu\Programs\Startup [xxx = User Login Name, If this user has local Admin privileges STARR is automatically installed for ALL users on this machine. If this user has restricted rights STARR is only installed for this specific user]

Directly after the first start the logging engine completes the setup. This includes removing the start-up link and replacing by a more secure startup mechanism. Also, the "starr.ini" file is automatically deleted.

Option 2: Use Login Script

This is the best option for large networks and where file sharing is not practical. Your login scripts needs to copy all logging engine files to the target machine and start the logging engine. After it is started, the logging engine invisibly completes the setup and deletes the "starr.ini" file automatically.

Option 3: Manuall installation using a "Clone" disk or network path.

This is the most simple option and can be used where option 1 and 2 are not practical: Simply copy all logging engine files in the appropriate folder on the target machine and start the logging engine once. After it is started, the logging engine invisibly completes the setup and deletes the "starr.ini" file automatically.

Note 1: The table the complete list of all necessary files can be found here .

Note 2: When you need to update the settings, create a new "starr.ini" file and copy to the client PCs. The logging engine automatically picks it up, reads the settings and deletes it at the next start up.

D. How to store the settings ("starr.ini" file)

To create the starr.ini file (needed for option 1 - 3) and the "starr.lnk" (needed for option 1) start STARR Commander. Then go to EMAIL / LAN >> LAN SETTINGS and click "STORE SETTINGS": The ready-to-use files are created.

Note: For easy testing, not only the logging engine (wsys.exe) can read the "starr.ini" file but also the STARR Commander.

E. Notes to Network Administrators

1. Make sure that the network (or local) directory exists and has full access rights (read and write) for all users! If a directory does not exists, STARR will ask you to create it when you press the "TEST" button on the LAN options page.

2. There is no limit to the size or type of network that STARR is installed on, and there are no requirements for any particular transport protocols. STARR is currently running on small peer-to-peer office networks and multi-server networks with 100+ machines, with mixed operating systems including Windows 95/98/Me/NT/2000 and Novell.

3. All you need is one shared folder on the Network. STARR will work on any machine that can write to that folder. Create an invisible shared folder by adding a "$" sign to the share name so that the end users cannot see it in Network Neighborhood.

4. The number of Client PC installations ("logging engine") allowed on your network is embedded in your license key. Installation of the STARR Commander are unlimited

5, If the connection to the network folder is lost at any point, STARR will save all information locally and resends it once the network connection is established again. This is especially important for a laptop that may be disconnected for long periods.

6. To make sure you have the correct path, we recommend that you use the "Browse" button on the LAN options page. There must be a slash "\" at the end of the directory path. If you forget it, STARR will add it for you :-)

7. STARR Commander has a command line option "-convert" for an easy (automated) conversion of STARR log files into reports:

8. You can use the remote deployment also to disable a STARR installation: Disable "Autostart" in the STARR Commander and create a new "starr.ini" file. Once this file is placed in the same directory as the logging engine (wsys.exe) the logging engine will read this file at the next start and stop itself from running at the following PC start.

9. Share Name Hint: You can setup an "invisible share" by proceeding you share name with a dollar sign ($). An invisible share is not shown in the list of shares on your computer, but can still be accessed by the share name (example: \\my-computer\shared$ where "my-computer" is the name of your computer on the network an "shared$" is the name of your hidden share).


Manual Installation

Installation Internals

Use the information in this chapter to create an automated installation for your network or to manually install STARR. It is easy: The STARR logging engine is a very compact software and consists only of 5 files !

A. File List:

You'll find all these files in the Starr home directory after a standard installation.

Filename

Description

Used where ?

Install where ?

wsys.exe

The logging engine

Client PC

Can be installed in any directory, for example c:\windows if you need to hide the file. If you move and/or rename the file you have to adjust the path to it in the "security" tab of the STARR Commander.

wsys.dll

The logging engine support file

Client PC

Can be installed in any directory, see wsys.exe above for details.

(starr.ini) (optional)

Preconfigured settings

Client PC

See Remote Deployment for details.

see32.dll

A standard windows file that contains networking capabilities

Client PC and Administrator PC

Install in the windows system directory, this is typically c:\windows\system on Win 95 / 98 / ME or c:\winNT\system32 on Win NT / 2000 / XP .

see32z.dll (optional) | A standard windows file that contains the ZIP capabilities | Client PC and Administrator PC | You need to install this file only if you want to zip the log file. Install it in the windows system directory, this is typically c:\windows\system on Win 95 / 98 / ME or c:\winNT\system32 on Win NT / 2000 / XP
see32u.dll (optional) | A standard windows file that contains additional ZIP capabilities | Client PC and Administrator PC | You need to install this file only if you want to use the visual monitoring (screenshot) feature. Install it in the windows system directory, this is typically c:\windows\system on Win 95 / 98 / ME or c:\winNT\system32 on Win NT / 2000 / XP

starrcmd.exe

Used for STARR setup and administration

Administrator PC

Can be installed in any directory.

Starr-Manual.chm
(optional)

This file!

Administrator PC

Install in same directory as starrcmd.exe or simply print it out.

Note: When you try to locate these file, please keep in mind that in most file managers (e.g. the Microsoft Windows Explorer) you need to enable the "display hidden / system files" option (or similar function) in order to see the "DLL" files. In the MS Explorer this option is located at View > Folder Options > View Tab > Go to the "Hidden Files" option and select "Show all".

B. Step-by-Step guide for a MANUAL installation

1. Do a standard installation on the (administrator) PC

2. Evaluate STARR and decide which settings you need

3. Copy the necessary STARR files to a disk. The files are marked with "Client PC" in the file list table (below). In addition, you need the STARR commander during the set-up or create a preconfigured "starr.ini" file.
4. Copy the files from your disk to a directory on the Client PC, e.g. "c:\windows" is typically a good choice.
5. Start the STARR commander on the Client PC and re-enter the settings (or use "starr.ini"), including your registration code. Make sure you activate the autostart option and check that the logging engine EXE and DLL paths point to the correct location of these files on the Client PC. To change the path for the STARR log (wsys.exe and wsys.dll), go to SETTINGS > ADVANCED SETTINGS and enter the new path name.

Alternative: Use the One-Click Installation
6. Delete the STARR commander on the Client PC (optional).
7. To evaluate a log file transfer it back to the Administrator PC or have it automatically send to you.


STARR Commander

The STARR Commander

The purpose of the STARR Commander utility is to help you with an easy setup of the logging engine configuration (What to log, how to log and where to send the log file) and also to decrypt and view the STARR log file that is created by the STARR logging engine. The logging engine itself runs invisibly in the background. The logging engine is either started manually by pressing the START button in the STARR Commander or automatically every time Windows is started, depending on the "Autostart" settings on the "Surveillance" part of the STARR Commander.

The following sections describes step-by-step, the different options that the STARR Commander offers.

  1. Dashboard

  2. Monitoring

  3. Settings

  4. Email / Network [Only PRO Version]

  5. Registration <-- Enter your activation code here

  6. About <-- STARR Online Support


Dashboard

On the dashboard page, you have full control over the logging engine, which runs in the background. It is not visible in the taskbar or the task list.

Start / Stop will start or stop the logging engine. The current state is displayed beside the buttons.

STARR report: Press VIEW to decrypt the STARR log file and create the report. The output can be formatted as interactive HTML text (the option preferred by most users), or as spreadsheet (e.g. Excel or as plain text. Depending on your selection, the STARR Commander starts your default browser, spreadsheet or text editor to display the report. For the display of plain text, Notepad is typically the default viewer. If the log file is too large for notepad, WordPad is automatically used. Hint: If you do not like the default formatting of WordPad, press "Ctrl + A" to mark the complete text and change the WordPad font to "Courier New", then everything has the same formatting as in notepad.

If you select "STARR log" the STARR Commander decrypts the raw log only. This is typically only of interest if you want to use the STARR log as input to another application.

Delete both log files on exit: This options helps you to leave no trace if you decrypt & view a log file directly on a target PC (i.e. a PC under surveillance). Once you exit the STARR Commander, both log files are automatically deleted, so there is no chance of leaving a decrypted log file on the PC.

Note: If you use your browser to view the log file, the viewed HTML log might be stored in the browser's cache (depending on your browsers settings). This means a copy of the report log may be accessible even though STARR deleted the original file. Solution: If the log file contains confidential data, make sure that the web browser's "cache" and "history" is cleared before you leave the PC so no unauthorized person can view the output using the browser's "history". (If you need to know how this is done, you can find instructions here (online).

Send Email: Tests the Email settings. Sends the log file immediately. Useful for testing your email settings.


Monitoring

Monitoring settings:

On this page, you can decide what kind of information you want STARR to log. The following examples are based on the interactive HTML report:

Visual Monitoring:

Screenshot: STARR takes picture of the PC desktop just like a surveillance camera. Click on the screenshot to enlarge it. When planning your security setup. you should keep in mind that screenshots occupy much more hard disk space then the text logs (see below.)
aaa

[05/15/2001 | 11:43:18] Screenshot:

Note: The screenshots are completed embedded in the interactive HTML log file, thus you can search for specific screenshots with keywords ! Only STARR offers this "Searchable Screenshots™" feature can save you plenty of time when reviewing the reports.

Text Monitoring:

STARR records text transcipts of all important activities:

1. Keystrokes: Logs what is typed on the keyboard. If the backspace key is used to delete text this is indicated with the <BS> sign.
Dear Sirs,
we want to order 10<BS><BS>30 copies of SD<BS>TARR for our company.
Regards, Irene Wang
x
2. Application titles. The title of the front application is logged whenever it changes. In the HTML report, a green background is used for the first appearance. If the title subsequently changes but the application is still the same, the title is shown with a yellowish background. The third value, [1:05] in this example indicates how long the application was used before the user switched to the next application. In this case, Word was used with the "cv" document for one hour and five minutes. In the spreadsheet type report, you can use this value to easily create lists of the "TOP 5" used applications and similar evaluations.

[05/15/2001 | 15:17:06] [01:05] Microsoft Word: cv.doc

[05/15/2001 | 18:19:26] [00:17] Microsoft Word: resume.doc
x
2a. Application path: the path of the current front application.
Path: c:\Program Files\Office\msword.exe
x
2b. Window class: The "class" of the current front window. This is a technical information generated by the operating system. This information is useful for support professionals that use STARR to trouble-shoot a PC problem.
[Class: IEFrame]
x
3. Time stamp: Useful to monitor working habits. STARR will "stamp" the log files even if no other activities occur, e.g. while you are out for lunch. You can set the time interval of the "stamp" in minutes.
Time Stamp: 12:17:45 / 02.14.2000
x
4. Edit boxes of popup's or applications. This logs the content of the (typically) "white" boxes in a popup or the content of simple text editors such as notepad.
Captured Popup Field(s)
503 123 4567
Ann Norris
San Francisco, CA
x
5. "Chat Spy". This logs both sides of a chat conversion: At the end of each chat conversation the complete content is summarized in the log file:
Chat summary No. 1: Ann - Instant Message
Chat #1:
Ann says:
Did you test the latest STARR release yet ?
Peter says:
Yes, it's great ! Download it now from http://www.iopus.com/download.htm ;-)
Ann says:
Thanks ! Bye !
x
6. "AOL Spy": Logs the content of text windows inside the AOL software, including chat and email.
AOL window summary No. 1: Email
Hi Ann,
I am currently using AOL and everything is recorded. Now we can keep an eye on our kids :-)
Peter
x
7. "WEB Spy": Logs the URL of visited web sites as a real life link. This allows you to just double click on the link in the log file to display the visited page in your browser!

[05/15/2001 | 16:27:06] [00:55] iOpus Software - Microsoft Internet Explorer -

(Path: c:\program files\Internet explorer\iexplore.exe)

+ Link: http://www.iopus.com/

+ Link: http://www.iopus.com/overview.htm

+ Link: http://www.iopus.com/download.htm

+ Link: http://www.iopus.com/service/feedback.htm

Ann

ann@iopus.com

This is an example of captured keystrokes while I am at a feedback form.

+ Link: http://www.iopus.com/store.htm

+ Link: http://www.yahoo.com

...


Settings

Security Settings:

A major feature of STARR is its ability to run invisibly in the background if required. This ability has made it a favorite tool with IT managers supervising PCs, PC support staff, employers, concerned parents and many others.

This page allows you to customize the STARR background operation and protect it against manipulation:

Popup : Built-in customizable message to notify the PC user that she / he is working under a monitoring program. You can customize the text of the popup to your needs. To make this popup more attractive and useful to the user, it also displays the time and date of the last logon.

Please note that iOpus believes that individuals who may be recorded with STARR should be informed in advance that they may be recorded and we STRONGLY encourage that you inform anyone whom you may record with iOpus surveillance software, e.g. by using this popup. Some countries may require this by law.

Backdating: A standard way that PC power users attempt to find out what happens on a PC, is to search for files created within the last x hours or days. With "backdating" STARR can escape this detection since the log file always has an "old" date - even when currently in use!.

Use internal buffer: By default, STARR uses the internal buffer of the windows operating system itself, to provide maximum security and speed. However, on some PCs this buffer is disabled (i.e. its size is 0), so every keystroke would be written directly to the hard disk. In this case, you can use STARR internal buffer which accumulates up to 200 keystrokes before it writes them to the hard disk. It never hurts to have this option on. The only drawback is, if your PC crashes for any reason, a maximum of 200 characters might be lost, since they may have not been written to the log file.

Delete log file size is bigger than xxx Bytes: For installations of STARR that run unattended for long periods, the log file can grow large. Keep your STARR software running completely maintenance free by using this function: If this function is active and the raw log file size exceeds the specified size, the STARR logging engine will automatically delete the current log file and start a new log file. If you use this function STARR runs completely maintenance free and you have always the latest information available.

Delete & Backup [PRO only]: In addition to deleting the log file, STARR backups the previous log file: When the given size limit is reached STARR copies the current log file to a backup file (named <your log file name> + "2") in the same directory as the current log file. Once backed up, the current log file will be reset to zero. If there is already a previous backup log file, it will be overwritten. That way you always have a log of the last xxx Bytes available without the worry that your hard disk might run out of space. Please note that you need to reserve at least twice xxx Bytes space on your hard disk (The maximum size of the log file plus the maximum size of the backup log file). The size of the STARR log file is checked roughly every minute to avoid unnecessary hard disk access. So the backup occurs with a slight delay.

Note: The size of the log file always refers to the compressed STARR log (not the converted reports).

If you need to read a log file from backup (or any other external STARR log file ) follows these steps:

  1. Hint: Make sure the logging engine is NOT running on your current admin PC while you use the STARR Commander to decrypt and/or convert the external STARR log.

  2. Enter the path to the STARR log file folder in the STARR log file location box in
    STARR Commander -> Settings -> Advanced Settings

  3. Make sure that the log file encryption / decryption password on the security tab in the STARR commander is the same (!!!) in the STARR commander on the target PC and on the administrator PC. Otherwise the decryption will "work" but the output file is still encrypted.

  4. Press "Create Report" on the Dashboard.

  5. Press "View" on the Dashboard to view the output file.

  6. Done !

Alternatively you can also use the STARR command line options.

PASSWORDS:

One MASTER PASSWORD can be used for several security features:

Log file encryption: A must if you want to prevent manipulation of the STARR log file: Even if the log file is detected, no unauthorized user can read it without using the STARR Commander and the correct password to decrypt it. If you do not enter a password, STARR uses an internal default. Note: Unlike with the password for the STARR Commander, there will be no popup asking for your password if you decrypt / display the log file, BECAUSE the log file itself is encrypted! This means the decryption is done always, but only if you have the correct password entered in the box, will the decryption produce a meaningful (readable) output. The password is Case sensitive !

STARR Commander Protection: To make sure only authorized persons can use the STARR Commander you can password protect it. Note: This is a separate password from the one used for the encryption of the log file (of course, you could use the same word if you like). The password is Case sensitive !

ZIP file password protection [PRO only]: Protect the emailed ZIP file with a password so only you can open it!


Settings

Advanced Installation settings:

Here you can adjust details of your STARR installation, e.g. to prepare STARR for a manual installation.

STARR log file: This is the log file created during the logging process. It can be plain ASCII text (i.e. viewable with any text editor) or a totally scrambled text if you choose to encrypt it (-> security settings). You can enter a path directly or use the BROWSE button. If you transfer a STARR log file from another PC to your administrator PC, you need to load it into the STARR Commander as a STARR log file in order to decrypt and display it (see also the Email section).

Path names: The invisible activity monitoring module ("Logging engine") consists of an executable and a so-called dynamic link library which contains program code used by STARR. You are totally free to rename both files. You could rename "wsys.exe" to "nice.day" and "wsys.dll" to "sunshine.hot" to hide them even from someone who might know the STARR filenames themselves. Once you have changed the names of these two files and / or their directory, all you have to do is change two path names in the STARR Commander.

Tip: Renaming starrcmd.exe: The file starrcmd.exe (the STARR Commander) is copied to your Windows directory (typically c:\Windows or c:\WinNT). You can easily rename this file: Example: You rename the file to GoodMorning.exe. Then you need to type "GoodMorning" into the RUN menu in order to start the STARR Commander.

Auto-Name: STARR can automatically name the log file, the email attachment (STARR report) and the email subject individually. This helps you to automatically sort and group your reports correctly. The currently available tags are:

<PC> Adds PC name

<USER> Adds user name. If you insert this tag in the log file name, STARR creates separate log files for each user !

<DATE> Adds the start-up date to the log file name. For the email attachment, the date when the report is emailed is added.

<TIME> Adds the start-up time to the log file name. For the email attachment, the time when the report is emailed is added.

By default, all four tags are added to the email attachment file name.

Uninstall STARR: Click here to remove STARR from the PC.


Email Settings

Remote Reporting:

STARR Professional can deliver the reports straight to your doorstep, i.e. your email box, using any standard SMTP / POP Internet email account or to your administration PC directly over you Local Area Network (LAN). With the help of the STARR "tags" (e. g. <PC>, <USER>, <DATE>, <TIME> ) the reports can be sorted according to your criterias.

1. Enter HOW you want the reports to be delivered:

  • No reports sent

  • Sent via Email <= Click for Details

  • Save via LAN <= Click for Details

2. Decide WHAT kind of report you want (Change selection on the dashboard) and if you want to include screenshots with your report. Screenshot are available in the interactive HTML report as well as with the STARR log file (the raw data).

If you include screenshots in your report, the report file is automatically zip compressed. This reduces its size for more than 90%.You can use any standard ZIP utility to unzip the log file again once received. If you want to know more about ZIP utilities, check out our GUIDE page at http://www.iopus.com/guides/zip.htm which also lists the TOP5 zip utilities.

Background information: When you select STARR log delivery you will receive two files: One containing the the text report (e. g. slog.sys) and one containing the screenshots (e. g. slog.sysz). The name for screenshot file is always "text file name" + "z". To view the content of the files select the path to the text file as input for STARR Commander (How to do this ?). The screenshot file is automatically read as well.

3. Decide WHEN you want the reports to be emailed. You can select a size criteria (e. g. every 2 hours) or email the reports once they reached a certainsize.


Email Settings

Email Reporting:

To get started emailing reports, all you need to enter is your email address!

By default STARR uses built-in email settings (which uses an iOpus email account to send the files). But you can also enter the settings of your own email account. This can be the address of your usual email account or the address of a second email account. In the first case you are basically emailing the file to yourself on this account. In the later case the second email account then serves as a "relay" to receive the file from STARR and emails it to your standard email account.

Note: If you need full control over the STARR email process we STRONGLY recommend that you use your own email account. We can not guarantee the availability of the built-in email. Furthermore iOpus reserves the right to modify or cancel this "built-in" email account at anytime without notice. For your convenience, iOpus maintains a list of the free SMTP / POP3 email account service providers at http://www.iopus.com/guides/bestpopsmtp.htm . STARR is designed to work with any standard SMTP accounts.

Email Options Overview

a.) Built-in email account

Target PC STARR logengine installed

»SMTP»

Email account maintained by iOpus Software

»Internet»

Your standard email, e.g. your company email or AOL. Does not need to support SMTP

»POP3»

Supervisor PC (STARR Commander installed)

  • This option requires no email setup! The basic function is the same as in option (b).

  • If you use STARR regularly, it is recommended that you use your own email account. iOpus reserves the right to modify or cancel this "built-in" email account at anytime without notice, e.g. in the case technical problems or abuse.

b.) Your own email account: Two account option

Target PC STARR logengine installed

»SMTP»

A (free) email server on the Internet

»Internet»

Your standard email, e.g. your company email or AOL. Does not need to support SMTP

»POP3»

Supervisor PC

  • The advantage of this option is that your real email account can be "anything" that accepts email (e. g. AOL). It does not have to support SMTP email sending.

c.) Your own email account: One account option (store the email directly in your account)

Target PC STARR logengine installed

»SMTP»

Your standard email, e.g. your company email. Must support SMTP.

»POP3»

Supervisor PC

  • Easy setup and the email is immediately stored in your email account. Your email account must support SMTP in order to do this.

Settings:

Tip: If you aren't sure of your email settings, look in the setup of your email client program (like Eudora or Outlook) or ask your system administrator. If you are using the "built-in email" option (a) you do not have to enter these settings.

SMTP: (always necessary)

(SMTP: stands for "Simple Message Transfer Protocol". The standard email protocol used to send emails on the Internet.)

Send from: Where does the email come from, the address of the email account you are using to send the email. (e.g. username@yahoo.com)

SMTP server: address of your SMTP server. Check with your email provider for this address, typically it says something like mail.provider.com or smtp.provider.com .

SMTP Port: The default port for emails is in most cases "25". In special cases it migth be necessary to use another email port, e. g. if your ISP blocks port 25. For up-to-date information please see our website.

POP3: (sometimes necessary)

(POP3 : stands for "Post Office Protocol". The standard email protocol used to receive emails)

"Normally" you would only need to enter the SMTP settings of your email account (since STARR only sends mail and does not receive it. However, some email service providers (e. g Yahoo Email) ask the user to check their mail first before sending. They do this for authentication purposes. If you need to check your mail first before you can send, you need to also enter your POP3 settings and check the box "Unlock account box". Otherwise leave the box unchecked.

POP3 server: address of your POP server. Check with your email provider for this address. Sometimes this is the same name as the SMTP server, but mostly not!

POP3 username: typically this is the first part of your email address (e.g. "username").

POP3 password: The password to access your POP3 account. Your email provider will tell you this. STARR itself stores your password encrypted for added security.

Tip: You can test your email settings by using the "Send email" button in the STARR Commander. This will send the current log file (or report) immediately.


Command Line Options

STARR Commander has a the -convert command line option for an easy conversion of STARR log files into reports:

Example:

1. slog.sys is STARR log that you want to convert

2. report.htm is the name of the report that STARR is going to create

Then you use:

  starrcmd -convert slog.sys report.htm

This instructs STARR Commander to convert slog.sys into the report with file name report.htm. If the starrcmd.exe is NOT in the same directory as the slog.sys file you need to specify full path names:

  starrcmd -convert c:\dir1\slog.sys c:\dir2\report.htm

Passwords and other settings are used as stored in STARR Commander.


Feature comparison chart
STARR Professional and Home Edition

Available Features: | PRO Edition | Home Edition
Surveillance
Visual Monitoring (Screenshots) |  |
"Searchable Screenshots™" |  |
Keystroke / password logging |  |
Application name logging |  |
Application path logging |  |
"Web Spy" (logs "live" URLs) |  |
"Chat Spy" (logs BOTH sides of chat*) |  |
"AOL Spy" (logs AOL content) |  |
Log Pop-Up's |  |
Time Stamp log file |  |
Create separate log files for each user |  |
Security
Stealth (invisible) mode |  |
Password protected setup |  |
Password protected log file |  |
Log file date freeze |  |
Log file size limit & auto-backup |  |
Installation
Installation Wizard |  |
Remote Network Deployment | ** | -
Manual Installation |  | -
Reporting
Interactive Report (HTML based) |  |
Text report |  |
Spreadsheet report (Excel...) |  | -
STARR log raw format |  |
Networking
Email the STARR log or report file |  | -
ZIP compress the log file |  | -
Save log file via LAN |  | -
Send report via LAN |  | -
Auto-name log and report file |  | -
Other features
Runs on Win 95 / Win 98 |  |
Runs on Win NT / Win 2000 |  |
One-year free email support |  |
Order STARR online: | Buy STARR PRO | Buy STARR Home

Remember that you can download and test both programs for 30 days. However, for technical reasons you should not run both programs at the same time.

(*) Both sides of the chat conversation are logged for AOL Chat, AOL Instant Messenger, ICQ, Microsoft Messenger, Yahoo Messenger.

(**)The remote network deployment is available for users with a multi-user or site license.

If you have problems deciding which version of STARR fits your needs, simply ask us at support@iopus.com !


Buy STARR now !

Buying STARR:

  • 100% Risk-Free M oney-Back Guarantee! - We are certain you will find our software useful, so we offer a 30-day money-back guarantee on every product we sell. So buy now !

  • The secure iOpus Online Store is operated by our e-commerce partner RegNow (Register Now), a division of DigitalRiver Inc. iOpus uses this prestigious and time-honored company in order to provide you with round the clock ordering services, plus state-of-the-art safety and security when using your credit card online.

  • Volume discounts, site licenses and discounts for non-profit organizations are available. Please see at http://www.iOpus.com/store.htm or contact us at sales@iopus.com for details.

You can order iOpus Software in so many ways:

 (A) ONLINE-REGISTRATION

Buy STARR in our Secure Online Store:

STARR PRO Edition, Order Number 1464-10, only US$ 69.95
(Click here to order STARR *PRO* now)

STARR Home Edition, Order Number 1464-9, only US$ 39.95
(Click here to order STARR *Home* now)

If you are unsure which version of STARR you need, please have a look at our feature comparison chart or ask us at support@iOpus.com .

After the purchase is completed, you will receive an email with your license key and the download link within seconds !
Enter this license key the during the installation and the software is unlocked, registered and fully enabled.

OR, you can use one of the other payment options:

 (B) Telephone and Fax Orders

Telephone:
Toll Free: 877-353-7297
International: 425-392-2294

Fax
Toll Free: 888-353-7276
International: 425-392-0223

(C) Paying by Check via Postal Mail

Please make sure that you make the check out to Universal Commerce, Inc. Please mail checks to:

Register Now!
ATTN: Orders
PO Box 1816
Issaquah, WA 98027
United States of America

(D) Purchase Orders

Purchase orders are accepted. Please contact us for details if choose to use the purchase order option.

(E) Other Options

For the most current list of all options please visit our homepage at http://www.iOpus.com/store.htm or contact us at support@iOpus.com .


Frequently Asked Questions (FAQ)

1. Purchasing:

Q: I would like to purchase and download STARR on the computer I am currently using, but install it on another computer. Is this possible?

A: Yes. The STARR installation file is compact and will fit on a single floppy disk. You may purchase and download on a computer and copy it to floppy disk, and then later install on another computer. Please note that the single user software license for STARR allows for one installation per purchase. Please also note that you are only allowed to install STARR on a computer you own. If you would like to install STARR on more than one computer, we offer multi-user and site licenses with great discounts.

Q: How do you count the licenses for the multi-user license ?

A: The installations are counted by the "STARR logging engine". Example: You have 10 PC's with the logging engine running and two PC's with (only) the STARR Commander to convert and read the log file. In this case you need the 10-user license. Installations of STARR Commander are free.

2. Installing:

Q: Am I allowed to install this software on somebody else's computer?

A: You may only install STARR on a computer that you own. Before you install the software, you must agree to use it only on a computer you own.

Q. Should I inform my employees or others that they are being monitored?

A: Yes. Some countries may require this by law. STARR has a built-in popup for this.

3. Operation:

Q: Does STARR log every application title, path etc.?

A: Yes, to our knowledge, the title and path of every application is logged.

Q: Does STARR log every keystroke ?

A. STARR logs almost every keystroke, with a few exceptions. Some applications do not allow for keystrokes to be logged, but these are very rare. The only ones currently known of are: the password fields in Pretty Good Privacy (PGP) and the NT / Win 2000 logon screen. If you come across any others, please let us know.

Q: Is the Win 95 / 98 / ME logon password recorded ?

A. Yes, it is (Please make sure that only authorized persons have access to the log file).

Q: Is the Win NT / Win 2000 logon password recorded ?

A. No.

Q: I received the log file via email but it looks "weird". What is wrong ?

A. Probably nothing! You probably choose the option "send STARR log". In this case STARR sends the raw, probably encrypted STARR log file . Choose "HTML", "Spreadsheet" or "Plain text" in order to receive "ready-to-use" reports.

Q: The spreadsheet report is not imported correctly into Excel ?

A. Excel can import Text files, which are stored in the comma separated value (CSV) format. Such a file contains the data in lines, whilst the fields are separated by commas. In normal cases Excel reads and converts this format automatically. Unfortunately there is a problem with Excel. Depending on the local Windows settings the separator may be either a semicolon or a comma. In German Excel the CSV file must contain a semicolon as a separator, to import the fields within the records into different columns of the worksheet.

4. Email: [PRO Version]

Q: Can STARR also send the log files via AOL ?

A: Email options (a) and (b) work fine with AOL. AOL uses its own proprietary email protocol and unfortunately not the Internet standard SMTP. Therefore you can not use option (c).

Q: Can you recommend any free email accounts for use with STARR ?

A. Yes, check out our very popular TOP 5 list of free SMTP / POP3 Email accounts at http://www.iOpus.com/guides/bestpopsmtp.htm

Q: Does STARR transmit any information back to an outside web site like some other Internet utilities do ?

A: No, of course not! The only information that STARR ever sends out is the STARR report or the STARR log file to YOUR email address if you choose to have the log file emailed. In addition, before emailing the log file, STARR determines if a PC is online. Technically STARR does this by trying to access an outside web site. This is done to make sure that no dial-up popup appears and the email process can run completely undetected. Technically this is the same a reading a web site with your browser, so no sensitive information is transmitted during this process. If you activate the function "Assume PC is always online" STARR skips this online check.

If you disable the "Email log file" function, STARR does not perform *any* Internet activity at all.

5. Security:

Q: How discrete is STARR ? Can anyone detect it?

A. If you select the log file backdating it is VERY discrete and almost impossible to detect since it does not appear on the task bar or even in the task list. For an invisible manual installation [PRO Version] simply follow the step-by-step guide in this manual.

Q: If people know STARR is installed, can they circumvent or manipulate the software without me knowing ?

A: STARR has many security features to prevent this: When installed invisibly, STARR does not show up as an icon, does not appear in the Windows system tray, does not appear in Windows Programs, does not show up in the Windows task list, cannot be uninstalled without the STARR Commander password which you can specify, and STARR does not slow down the operation of the computer it is recording.

If the log file is emailed out or saved on a network server it is not accessible for the user of the local PC and can not be deleted. Even when stored locally, it is impossible to manipulate the log file without breaking the STARR encryption scheme first. But as with any filter, surveillance or security software, a computer expert could ultimately disable or delete the STARR installation, but this will not go unnoticed by you !

Q: Why is STARR so small ? Other apps which do similar things need a 7.0 MB download ?

A. STARR is written in "pure" C/C++ code, which can be compiled into very small, yet powerful executables (Remember, only about ten years ago a whole operating system did not need more then 16 Kbytes!). Secondly, STARR is designed to make as much use of the Windows operating system as possible. The advantages are obvious: The more we utilize the Windows operating system itself, the smaller and more discrete STARR becomes.

6. Miscellany:

Q: Where can I find more information ?

A: You can find more information on the iOpus homepage, for example:

  • STARR Online Frequently Asked Question

  • STARR Online Bug reports

  • STARR user feedback

  • Articles & Links about the PC & Privacy issue

  • The popular iOpus TOP5 list of the best free email accounts

  • And more ....


x

iOpus Software:

Software | Quick Overview
STARR Pro Edition | STARR PRO EDITION contains all the features of the HOME Edition plus the features you need in a professional environment: Flexible network functions allow you to send and receive reports via the Internet or the corporate LAN. It contains advanced setup and reporting functions and is prepared for remote deployment inside the local network. STARR PRO is employed frequently by small businesses, "Fortune 500" companies, schools, universities and the military alike. Compare with STARR Home Edition
STARR STARR Home Edition | STARR HOME EDITION is designed for the use on a stand-alone PC, e. g. for parental control or for recording your own work for later reference. STARR HOME is the best choice for parents who wish to monitor what their children are doing online. It is an excellent alternative to standard filtering and blocking software. Compare with STARR PRO
42 BEEE | BEEE, Better Email Enable Everything, is a unique internet email tool that allows you to supervise every kind of file & folder on your PC and email it automatically to your SMTP / POP3 email account. BEEE supports MAPI connections to your default email account, automatic ZIP-compression and command line options for an easy integration Great for office automation (email your invoices automatically etc.)

xx
Freeware | Quick Overview
123 Write All Stored Passwords (WASP) | Passwords: WASP displays all stored passwords of the currently logged on user that are hidden in the Microsoft PWL file. It allows the convenient supervision or deletion of this file to improve the security / privacy of your PC (for Win 95, 98, ME only).
123 Password Recovery | Passwords: Windows allows the storage of frequently used passwords. However, since you no longer enter the passwords manually, you tend to forget them. What are you to do when you need to know one of the saved passwords ? The password is staring right at you, but is hiding behind a row of "*****" asterisks. This nifty utility allows you to reclaim your password.
42 AC-Plug | 42 Always Connected "Plug": Usually Dial-In Internet provider disconnect users if they are not "actively surfing" for a certain period of time. This software prevents the disconnection from happening. The AC-Plug sends periodic signals that will keep your internet connection active until YOU decide to disconnect.

x
iOpus Software is designed to be Windows platform independent, i.e.. it runs on Win 95, Win 98, Win ME and Win NT/2000/XP unless stated otherwise.


Introduction

Email Newsletter

If you want to be notified about new iOpus software, bug fixes or updates, we recommend that you join our free NEWSLETTER mailing list:

To subscribe simply send an (empty) email to

iOpus-SUBSCRIBE@LISTBOT.COM
(Click link to open your default email client)

or

to go to our web page and subscribe online.
We are dedicated to a policy of not SPAMing. We only send out update notifications to validated emails of individuals who have requested this information. The LISTBOT service will email you an invitation to join our list. You only need to reply to the address to join the list.

This software update is periodically sent as new software releases become available. It is also the only way to get access to early beta versions and inside information! We will not sell your email address.


x

About iOpus Software products:

iOpus' field of expertise includes Internet-based applications and Windows security. Our software is developed based on the needs and requirements of users like yourself as we always keep an eye open as we scout for new and fresh ideas to incorporate in our product development.

Our main priority and goal is customer satisfaction. We achieve this by listening to our clients and incorporating their requirements into our programs. In fact, more than 50% of the enhancements in our applications come from clients' feedback.

Another important decision we made, was to release our software as shareware. This allows prospective customers to evaluate our applications totally risk free, within a trial period, to determine if the program meets their requirements. We never ask for money first, preferring to provide exactly what you need at a very low cost.

Our clients continue to pay a very fair price, as low as we could practically make it. For this reason, and because our users tell us they prefer it, we did have to cut back on certain things, such as printed manuals, physical delivery and phone support. Despite those slight cuts, we do not cut down on technical support and provide both comprehensive help files and email support (we usually reply within a day). We dispensed with physical delivery of our products, and focus on ESD (Electronic Software Distribution). This has helped to reduce the cost of our products, especially for our overseas clients, and as we regularly come out with updates to our applications, a hard copy could be out of date by the time it reached you.

If you have suggestions or questions, please do not hesitate to contact us at support@iOpus.com !

Contact information:
Email | Fax
Sales questions: sales@iopus.com | USA: +1-253-679-0811
Technical support: support@iopus.com | UK: +44-870-831-9234
Press inquiries: press@iopus.com | Germany: +49-6227-841-9605